Page 1 of 1

Kali Linux Issues [HELP]

PostPosted: Mon Dec 22, 2014 9:02 am
by RatkinHHK
Solved:
Code: Select all
[i] "Finally installed Kali LInux on my machine, and I cannot properly connect to the internet. I am on Kali now, using the hotspot from my phone.

So, I have a cable based internet connection, where you type the username and password recieved from the ISP. I tried in Kali with the GUI, but nothing happens. So after some digging, I am told I need to use the terminal and setup pppoe with something like: sudo pppoeconf or sudo pppoe-setup etc. But I always get "command not found". Cookies for the one who saves me. Bear in mind however I am very inexperienced with Linux."[/i]


>>>
Now...
When I try to install chrome I get this error:
Code: Select all
(Reading database ... 317076 files and directories currently installed.)
Preparing to replace google-chrome-stable 39.0.2171.95-1 (using google-chrome-stable_current_amd64.deb) ...
Unpacking replacement google-chrome-stable ...
dpkg: dependency problems prevent configuration of google-chrome-stable:
google-chrome-stable depends on libappindicator1; however:
  Package libappindicator1 is not installed.

dpkg: error processing google-chrome-stable (--install):
dependency problems - leaving unconfigured
Processing triggers for man-db ...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Processing triggers for menu ...
Errors were encountered while processing:
google-chrome-stable

The package is downloaded from the official site. Please remember that I have literally 2 hours LInux experience. Thanks in advance

Re: Kali Linux Issues [HELP]

PostPosted: Mon Dec 22, 2014 3:03 pm
by cyberdrain
So I'm guessing the log states exactly what you need to do. Dependencies are packages on which a program depends. A simple example, if I write a Python script and I want it to run on another box, it needs to have Python installed. In most *nix systems dependencies usually are automatically fulfilled, but maybe because you downloaded this manually this system didn't work. So what you have to do is given her:
RatkinHHK wrote:Package libappindicator1 is not installed.

So, apt-get install libappindicator1 should solve the problem. If that package cannot be found, add the Debian sources to your sources.list iirc should solve that too. Good luck and let us know how it went. :)

Re: Kali Linux Issues [HELP]

PostPosted: Mon Dec 22, 2014 5:56 pm
by RatkinHHK
... No worries. I am only 5 minutes away from a mental breakdown.

I managed to find tons of repositories out of which no more and no less than 0 worked. So I downloaded the package manually. It asked for 4 other things. I got a glass of water, calmed down, and downloaded the first of them. And this one needs something I already fu**ing have! G*d **@@@ #### .... [*loud screams] ... #$$$# .... [* sound of table flying of the window] .... ^^^&&&##@)))) .... [*silence] .... [*footsteps]

Let's continue, shall we?
This is the error message. Is it a problem that it took me 2 hours to fail at installing Chrome? Do I still have the right to visit hackthissite? Too late for another carrer? Is it just that Kali is complicated and lacks a lot of packages?

Code: Select all

(Reading database ... 316843 files and directories currently installed.)
Preparing to replace libdbusmenu-glib4:amd64 12.10.2-1 (using libdbusmenu-glib4_12.10.2-1_amd64.deb) ...
Unpacking replacement libdbusmenu-glib4:amd64 ...
dpkg: dependency problems prevent configuration of libdbusmenu-glib4:amd64:
libdbusmenu-glib4:amd64 depends on libglib2.0-0 (>= 2.37.3); however:
  Version of libglib2.0-0:amd64 on system is 2.33.12+really2.32.4-5.

dpkg: error processing libdbusmenu-glib4:amd64 (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
libdbusmenu-glib4:amd64


And when I try to install libglib2.0, it says it is already installed...

Re: Kali Linux Issues [HELP]

PostPosted: Mon Dec 22, 2014 7:02 pm
by cyberdrain
OK, so I just learned that while it's possible to add repos of Debian to Kali, it's not recommended (e.g. it breaks things). Here's a resource I found that might help somewhat: Installing Google Chrome on Kali part 2. First check that the linux_signing_key is correct, otherwise you'll be adding garbage to apt-key. If you don't want to check, just run the command below as is, otherwise run the code on the bottom instead. After running the first command, reboot and run the rest as root to install Chrome.
Code: Select all
wget -q -O - https://dl-ssl.google.com/linux/linux_signing_key.pub | sudo apt-key add -
echo "deb http://dl.google.com/linux/chrome/deb/ stable main" >> /etc/apt/sources.list
apt-get update && apt-get install google-chrome-stable

Let me know if that worked.

Alternatively check whether the key is correct and only add it afterwards (continue with echo... above):
Code: Select all
wget -q -O - https://dl-ssl.google.com/linux/linux_signing_key.pub > google_sign_key.pub
cat google_sign_key.pub
cat google_sign_key.pub | sudo apt-key add -

Re: Kali Linux Issues [HELP]

PostPosted: Mon Dec 22, 2014 7:24 pm
by RatkinHHK
Still needs stuff which I cannot find with "apt-get install". So we still have the same issue. See above anger management fail episode for the exact name of the problem packages. Among others...

I still thinks all I need is a W.O.R.K.I.N.G. list of repositories. About the fact that it may break stuff, I will remove the repositories after I install all I need. Damn, this Chrome. When I thinks I still have to install Flash, Java and perhaps some compilers...

Re: Kali Linux Issues [HELP]

PostPosted: Mon Dec 22, 2014 7:39 pm
by cyberdrain
There's a list for all of those, besides, fixing the sources.list is easy to do. Just look for the '20 things to do after installing Kali' list for answers to your questions. If that doesn't fix it, I'll have to do some more digging and so should you ;) Hang in there.

Re: Kali Linux Issues [HELP]

PostPosted: Tue Dec 23, 2014 10:12 am
by RatkinHHK
Eventually solved this. Thanks.
I'm calmer now.

Re: Kali Linux Issues [HELP]

PostPosted: Tue Dec 23, 2014 3:26 pm
by cyberdrain
Nice, please tell me what you did. I'd like to see what I missed or if something helped. :)

Re: Kali Linux Issues [HELP]

PostPosted: Tue Dec 23, 2014 6:26 pm
by RatkinHHK
I eventually found a webpage which provided some good repositories. Also I was instructed to
Code: Select all
apt-get update && apt-get upgrade && apt-get dist-upgrade
apt-get  -f install
which deleted something and installed a whole bunch of stuff. Took around 25 mins. I still do not know exactly what the code does, but I'll get there. I still do not understand why a package required something I already had, or why all those initial repositories didn't work. Your guess is as good as mine.

-- Thu Dec 25, 2014 1:32 am --

.... Question:

Should I create another user, or is it okay to run as root? And does root have more privileges than "Administrator" accounts?

Re: Kali Linux Issues [HELP]

PostPosted: Mon Jan 05, 2015 5:14 pm
by cyberdrain
RatkinHHK wrote:Should I create another user, or is it okay to run as root? And does root have more privileges than "Administrator" accounts?

Well, it might be a bit late to answer this one, but this is pretty obvious if you would search the web for it. The root usually is the administrator account of *nix systems. Rights management on *nix systems is a lot more thought out from the start than it was on Windows systems, so you might want to read up on how this works in Linux. Better yet, pick up a book about its basics, I found that a good source as any to start learning a lot about the underlying system.

Oh and to answer your first question: unless you know what you're doing or you're running a live USB system (in which case you sometimes have to live with it), NEVER run as root. There's a reason Ubuntu doesn't even allow you to access the root account in default settings (requiring sudo for everything). Disable the root account on Kali and e.g. change settings so WireShark runs without requiring root. Also make sure you add the Kali repositories on a newly installed system, otherwise you're not going to get all updates.