Stego 1

Find what's hiding in plain sight

Re: Stego 1

Post by sirvanschaik on Mon Jan 18, 2010 2:37 pm
([msg=33518]see Re: Stego 1[/msg])

i added one thing to the binary and got a 7 character alpha-numeric password and it looked right but it says its wrong. Am I adding something wrong?

EDIT
Ok I was adding in the wrong place. sorry to bother everyone.
sirvanschaik
New User
New User
 
Posts: 7
Joined: Mon Jan 18, 2010 2:32 pm
Blog: View Blog (0)


Re: Stego 1

Post by shill on Sun Mar 07, 2010 9:31 pm
([msg=36282]see Re: Stego 1[/msg])

edit: wait, what? Apparently I completed it but never got the message. Nevermind.
shill
New User
New User
 
Posts: 10
Joined: Mon Jan 11, 2010 2:50 pm
Blog: View Blog (0)


Re: Stego 1

Post by rapistebe on Tue Apr 06, 2010 3:25 pm
([msg=37789]see Re: Stego 1[/msg])

well.. what i did, is to find 2 null bytes 0000, i found it twice in the bmp body (not in the header), I deleted them, and aded another 2 null bytes at the end of the file, and I get the same image but it has a black bar on the right (where the original image was suposed to end) but i see no pass to the right of that black bar
edit:
I continued hex editing the image, even in the header, and i kind of removed that black bar, aparently no changes were made to the image, but when I compare it to the original, I find that the logo was moved to the left of the image, maby Im in the right track, but I dont see any pass yet
edit:
maybe is not that the logo moved to the left, but that the image width increased
edit:
i found and replaced all null bytes that I could, without corrupting the file, the image width didnt change since my last try, but a vertical bar apeared to de right of the image, now its kind of a glow, its like the white glow you see in some borders of the image but I still dont see any pass
rapistebe
New User
New User
 
Posts: 1
Joined: Tue Mar 30, 2010 10:41 am
Blog: View Blog (0)


Re: Stego 1

Post by Defience on Tue Apr 06, 2010 3:48 pm
([msg=37794]see Re: Stego 1[/msg])

That's not really the right track.....
User avatar
Defience
Addict
Addict
 
Posts: 1275
Joined: Thu Jun 12, 2008 3:16 pm
Blog: View Blog (0)


Re: Stego 1

Post by destructo131 on Sat Apr 10, 2010 5:54 pm
([msg=38032]see Re: Stego 1[/msg])

I'm actually really confused with this mission! I managed to do 3 and 4 easy... 2 isn't image stego' so I'll have to research that, but 1 0_0 it is too hard for me... I've found 2 null bytes... I just don't know where to go from here, maybe I'mm looking too deep into it? Can someone please give me a nudge in the right direction?

Thank you :)
destructo131
New User
New User
 
Posts: 2
Joined: Mon Apr 14, 2008 9:00 am
Blog: View Blog (0)


Re: Stego 1

Post by omicrom on Sun Apr 11, 2010 1:10 am
([msg=38077]see Re: Stego 1[/msg])

Ok so i found completed mission one and it felt great to be back in the world of bits bytes and chars but one small thing at the end bothered me. At the end i had it narrowed down to only a few choice i just brute forced the rest of the way. Since i am new i wanted to know if brute forcing was the correct way to go and if brute forcing is kosher when it is just an limited amount of choice remain and becomes educated guesses?

Thanks for your time
omicrom
New User
New User
 
Posts: 10
Joined: Fri Apr 09, 2010 2:59 pm
Blog: View Blog (0)


Re: Stego 1

Post by sda1 on Tue May 11, 2010 8:00 pm
([msg=38578]see Re: Stego 1[/msg])

I am a bit curious. I played around with the missing info, moving it from here to there, and using the results as my password.
nothing seemed to be working. I never got a congratulations, but my profile now shows that I have completed the mission. :?
is that a glitch or did I just miss it or something?
sda1
New User
New User
 
Posts: 3
Joined: Tue May 04, 2010 7:24 pm
Blog: View Blog (0)


Re: Stego 1

Post by Acidblade604 on Fri May 14, 2010 9:27 pm
([msg=38671]see Re: Stego 1[/msg])

That was a nice quest, finding the right place for the lost thing was the thing, one has to have good intuition to find it, however you shoud get a bit more points for this challange :)
Acidblade604
New User
New User
 
Posts: 3
Joined: Wed May 05, 2010 7:10 pm
Blog: View Blog (0)


Re: Stego 1

Post by jf20 on Wed May 19, 2010 2:07 pm
([msg=38803]see Re: Stego 1[/msg])

Ok.. so after solving this one I have to say
i found no logical reason for that position to be the position he missed...
If anyon eknow a logical reason for that i would love to know (please PM me thanks)
jf20
New User
New User
 
Posts: 1
Joined: Wed May 19, 2010 1:59 pm
Blog: View Blog (0)


Re: Stego One

Post by andro1d on Sat Jul 10, 2010 12:32 am
([msg=41521]see Re: Stego One[/msg])

haha01haha01 wrote:
BhaaL wrote:You're not supposed to need brute-forcing there.
Tiksi (the one who made the mission) simply made a mistake and forgot something. Yet, he didn't forget it randomly, but in a certain place - no brute-forcing required, at least none that needs you to write an app for it.

Well I ended up brute forcing it and completed the mission pretty easily. I still don't understand how could I do it without brute forcing, the place that the missing something was supposed to be in doesn't make any logical sense to me and seems like it was chosen randomly.


You're right, it's not a logical position, but it's definitely not very difficult to add bits to the starts of each byte and try the possibilities in order from start to end (and obviously whilst looking for data that doesn't look like garbage). It took me 2 attempts (after attempting start and end bytes first).

A suggestion to find the target section would be look at the hex and think binary (which is made up of a combination of 2 different bits 0's and 1's) and how it could be represented in the targeted area.
andro1d
New User
New User
 
Posts: 7
Joined: Fri Jul 09, 2010 11:39 pm
Blog: View Blog (0)


PreviousNext

Return to Steganography

Who is online

Users browsing this forum: No registered users and 0 guests