Web Server

Discuss the many weaknesses of browser security and ways to mitigate the threat

Web Server

Post by G Man on Wed Mar 03, 2010 11:06 am
([msg=36026]see Web Server[/msg])

Hi Folks,

First off, apologies if I have posted this in the wrong section....

I wish to run a small website from my home PC, I have never done anything like this before. So far I have downloaded and installed Apache 2.2, when typing http://localhost into my browser I can see "It works!". Also I have port forwarded port 80 in my router for the local IP of my PC.

Outwith my network, at work, when I type in my router IP address should it display the "It works!" html document? If not what have I missed or not done correctly? At present all I get is connection timeout error.

If it helps I have an Etec PTi-845g router and I am using Windows XP

Thanks,

G
G Man
New User
New User
 
Posts: 5
Joined: Sat Oct 03, 2009 12:50 pm
Blog: View Blog (0)


Re: Web Server

Post by nermd on Wed Mar 03, 2010 12:29 pm
([msg=36032]see Re: Web Server[/msg])

i guess the router or your PC has some kind of firewall which is blocking the requests. Or maybe you have done something wrong with the port forwarding set up.
Another thing could be your ISP, a lot of ISPs have TOS that do not allow normal customers running public server systems under their home accounts. So maybe your ISP is blocking port 80 at all ...
With this world there is no understanding, we belong their only to the extent, as we rebel against it (Theodor W. Adorno) --> if somebody knows a "official" translation for the well known german quote ... pls let me know!
User avatar
nermd
New User
New User
 
Posts: 42
Joined: Fri May 23, 2008 3:22 am
Blog: View Blog (0)


Re: Web Server

Post by orwell84 on Thu Mar 04, 2010 6:02 am
([msg=36086]see Re: Web Server[/msg])

This is probably redundant, but your computer was on when you tried to access it from work, right?
Mens et manus.
User avatar
orwell84
Poster
Poster
 
Posts: 112
Joined: Fri Feb 20, 2009 8:20 pm
Blog: View Blog (0)


Re: Web Server

Post by computerbp13 on Thu Jul 01, 2010 10:41 am
([msg=41130]see Re: Web Server[/msg])

orwell84 wrote:This is probably redundant, but your computer was on when you tried to access it from work, right?


To add to the redundancy: If the computer was on, Apache was running, correct? Also, just curious, but who's your ISP? I have Comcast that they allow my small setup that I use for small projects. On that note, the problem might be a bit more local. Try accessing the page from 127.0.0.1 (this should work) then try from your internal IP (check your router, usually in the range of 192.168.1.100+). Next try your IP address from the computer running apache. This will verify that a) your work just doesn't have you IP blocked for some reason and b) you don't have a firewall preventing apache from serving content.
computerbp13
New User
New User
 
Posts: 9
Joined: Fri Jul 04, 2008 12:24 pm
Blog: View Blog (0)


Re: Web Server

Post by msbachman on Thu Jul 01, 2010 1:52 pm
([msg=41136]see Re: Web Server[/msg])

Rough list:
1) Replace the default index.html with your site material
2) Check the site to ensure proper functionality
3) Consider looking into a service like dyndns.org (free for most users) to track your IP address if it could change from being NAT'ed.
4) Open port on home router to allow incoming traffic to connect to port 80.

5)
Code: Select all
if(iscompromised(apache))
printf("%s\n", "You're fucked.");
else
printf("%s\n", "success!");
"I'm going to get into your sister. I'm going to get my hands on your daughter."
~Gatito
User avatar
msbachman
Contributor
Contributor
 
Posts: 681
Joined: Mon Jan 12, 2009 10:22 pm
Location: In the sky lol
Blog: View Blog (0)


Re: Web Server

Post by insomaniacal on Thu Jul 01, 2010 3:18 pm
([msg=41139]see Re: Web Server[/msg])

You have to make sure your router is pushing things that it receives on Port 80 to you. There's most likely an error somewhere in the port forwarding process.
It's not who votes that counts, it's who counts the votes
insomaniacal.blog.com
User avatar
insomaniacal
Addict
Addict
 
Posts: 1210
Joined: Sun May 24, 2009 10:21 am
Blog: View Blog (0)



Return to Web

Who is online

Users browsing this forum: No registered users and 0 guests