a problem about update msf in bt5

There are many different operating systems; which one will you choose?

a problem about update msf in bt5

Post by 0x557vm on Tue Apr 12, 2016 7:38 am
([msg=92122]see a problem about update msf in bt5[/msg])

8-) hello~
im a university student from China,and i knew here in last year :)
im poor at English ,it might be hard to read my 'Chineseenglish' .but id like to communicate with your.

these days i want to update the msf in bt5r3,for do some experiments.but it return a error in bundle of msf.
/
Bundler could not find compatible versions for gem "bundler":
In Gemfile:
cucumber-rails (>= 0) ruby depends on
bundler (< 2.0, >= 1.3.0) ruby

Current Bundler version:
bundler (1.1.2)

This Gemfile requires a different version of Bundler.
Perhaps you need to update Bundler by running `gem install bundler`?
/
ruby cant update,either.
:shock: and it makes me envy that there's no gfw outside...

-- Tue Apr 12, 2016 4:40 am --

i have try many methods,but it didnt work.
0x557vm
New User
New User
 
Posts: 3
Joined: Tue Apr 12, 2016 7:12 am
Blog: View Blog (0)


Re: a problem about update msf in bt5

Post by LiquidLemon on Tue Apr 12, 2016 11:45 am
([msg=92123]see Re: a problem about update msf in bt5[/msg])

0x557vm wrote:i have try many methods,but it didnt work.

That's not very descriptive. Did you try updating the bundler gem manually as suggested? Did you maybe try removing bundler from the Gemfile?

Aside from that Backtrack has now been replaced by another distro called Kali Linux. It's pretty much the same thing but it is still being developed. You might run into some other problems caused by outdated software in Backtrack so it would be for the best if you just moved over to Kali.
User avatar
LiquidLemon
New User
New User
 
Posts: 33
Joined: Sun Oct 26, 2014 2:26 pm
Blog: View Blog (0)


Re: a problem about update msf in bt5

Post by cyberdrain on Wed Apr 13, 2016 7:46 am
([msg=92135]see Re: a problem about update msf in bt5[/msg])

Note that in the newest version of Kali there were some changes in the Metasploit framework. Some parts are not included any more.
Free your mind / Think clearly
User avatar
cyberdrain
Expert
Expert
 
Posts: 2160
Joined: Sun Nov 27, 2011 1:58 pm
Blog: View Blog (0)


Re: a problem about update msf in bt5

Post by 0x557vm on Fri Apr 15, 2016 11:31 am
([msg=92149]see Re: a problem about update msf in bt5[/msg])

LiquidLemon wrote:
0x557vm wrote:i have try many methods,but it didnt work.

That's not very descriptive. Did you try updating the bundler gem manually as suggested? Did you maybe try removing bundler from the Gemfile?

Aside from that Backtrack has now been replaced by another distro called Kali Linux. It's pretty much the same thing but it is still being developed. You might run into some other problems caused by outdated software in Backtrack so it would be for the best if you just moved over to Kali.


ths!
absolutetly i know kali and i also use it now .The problem is that i want to set up a circumstance for some tests.just now,i occur to the problem must due to GFW......GFW prevent the data transfer..and can't link to source on Amazon . and im looking for mirror site :shock:

-- Sat Apr 16, 2016 12:33 am --

cyberdrain wrote:Note that in the newest version of Kali there were some changes in the Metasploit framework. Some parts are not included any more.




thanks~i also use kali 2 now~ :mrgreen:
0x557vm
New User
New User
 
Posts: 3
Joined: Tue Apr 12, 2016 7:12 am
Blog: View Blog (0)


Re: a problem about update msf in bt5

Post by cyberdrain on Mon Apr 25, 2016 5:35 pm
([msg=92206]see Re: a problem about update msf in bt5[/msg])

0x557vm wrote:Thanks~i also use kali 2 now~ :mrgreen:

You're welcome, have fun!
Free your mind / Think clearly
User avatar
cyberdrain
Expert
Expert
 
Posts: 2160
Joined: Sun Nov 27, 2011 1:58 pm
Blog: View Blog (0)



Return to Operating Systems

Who is online

Users browsing this forum: No registered users and 0 guests