VMware Networking Issue

What's the best way to setup a home network? Why should I care about BGP?

VMware Networking Issue

Post by r0y4lty on Tue Dec 22, 2009 5:41 am
([msg=31693]see VMware Networking Issue[/msg])

Hey everybody, I'm not that familiar with vmware but I know how to set up bridged networks on my machine and all the basics. First, if i have one of the connections assigned as NAT the network connection is showed as Unidentified Network in the Network and Sharing Center through the Control Panel on my Windows Vista machine. SO when i set up lets say VMnet0 (in Virtual Network Editor) to a bridged connection and I change it from automated bridge to NVIDIA nForce 10/100 Mbps Ethernet (my ethernet adapter) and select apply it doesn't show up with the NAT connection in control panel.

So, I can't seem to bridge my Local network with the bridged connection set up with the Virtual Network Editor because it's not there to bridge. I've tried to do the same procedure with the NAT connection and then changing it to bridged after i have bridged those to connections together in control Panel. Restarted the computer and everything, reset the Comcast high Speed Internet modem but it still show that the network/connection was unidentified and of course showed limited connectivity.

I don't have any firewalls set up at the moment no router, my AV is Avira and i have Spyware Doctor running. I've also tried the same thing while my AV and the doctor wasn't running but no success.

P.S. If you want to know why I am trying to bridge them together, is so I can connect to an ssh set up service on a linux virtual machine so i can connect to it remotely.

If you guys need any more information in case I have missed something please tell me and I will provide it. Also if i have posted it in the wrong section, I'm sorry. :D
Thank you, r0y4lty.
New User
New User
Posts: 6
Joined: Thu Oct 01, 2009 12:13 pm
Blog: View Blog (0)

Re: VMware Networking Issue

Post by thetan on Tue Dec 22, 2009 11:27 am
([msg=31712]see Re: VMware Networking Issue[/msg])

Hey r0y4lty,

In order to establish an ssh connection to the virtual machine, a bridged connection is not required. VMNet0, VMNet1, VMNet2, etc are nothing more then virtual NIC interfaces, they exist only as clever interface hackery of you're already existing NIC hardware.

If you are having issues SSH'ing to you linux VM then the problem has nothing to do with a lack of a bridged connection as the Virtual NIC's set up by VMPlayer should work into tricking the ethernet cable running to your computer to think that it's connection to multiple interfaces.

Typically the problem will lay with either of the following:
  • You need to configure /etc/network/interfaces or whatever DHCP client you're using
  • Make sure your firewall isn't blocking remote SSH access

Typically if you can't connect to anything at all through the virtual environment, this is a definitive result of an improperly configured interface. Nothing to do with bridging as the 2 "seperate" interfaces are actually the same NIC.

By the way, i have to put my plug in and promete VirtualBox-OSE over VMWare, it's Sun's VM baby and i use it all the time at work because it's the effin shit dawgzz!!
"If art interprets our dreams, the computer executes them in the guise of programs!" - SICP


“If at first, the idea is not absurd, then there is no hope for it” - Albert Einstein
User avatar
Posts: 657
Joined: Thu Dec 17, 2009 6:58 pm
Location: Various Bay Area Cities, California
Blog: View Blog (0)

Return to Networking

Who is online

Users browsing this forum: No registered users and 0 guests