Application 1

Learn to reverse engineer through some common application security methods.
Forum rules
DO NOT POST ANSWERS OR SPOILERS! [IE: Mission Links, Mission File Names/Pages, Scripts/Code, etc.]

Posting these will result in warnings/bans!

Re: Application 1

Post by occamsrzr on Mon Jul 14, 2014 10:09 pm
([msg=82240]see Re: Application 1[/msg])

GeneralPet wrote:May I ask something? The program requires a serial number so I can verify my license... So is this what I have to find out?


Slight hint; In this instance, finding the (a?) valid serial might be the easiest method. It won't always be though, just because of the way this binary was written.
occamsrzr
Experienced User
Experienced User
 
Posts: 60
Joined: Wed Aug 24, 2011 10:28 pm
Blog: View Blog (0)


Re: Application 1

Post by nexo on Wed Aug 27, 2014 10:22 pm
([msg=83025]see Re: Application 1[/msg])

I think the linux version is broken. Solved it with the windows one...

Edit: you can solve it on linux using the win version + wine.
Edit 2: Little linux folks hint: $ hexdump -C filename might be usefull.
nexo
New User
New User
 
Posts: 6
Joined: Tue Aug 26, 2014 10:12 pm
Blog: View Blog (0)


Re: Application 1

Post by curiosity314 on Sun Jul 02, 2017 9:18 am
([msg=93886]see Re: Application 1[/msg])

Solving this one was easy, but I've been wondering what sorts of countermeasures were taken to make it so darn hard to crack with olly or ida? What happened here?
curiosity314
New User
New User
 
Posts: 2
Joined: Sun Jul 02, 2017 9:08 am
Blog: View Blog (0)


Re: Application 1

Post by m0nk3y-1 on Sun Sep 17, 2017 1:44 pm
([msg=94272]see Re: Application 1[/msg])

roblabla wrote:I just wanted to point out that I cannot uncompress ANY of the mac files ! I tried all of the decompresser, none works ! They are compressed under the .sit, maybe I'm not doing something right.
What i do :
I installed Stuffit Expander (which i use almost every day, and works).
I download app1mac.sit through google chrome (heh, did not try any other way to download… i might need to try that).
I double click/drag and drop app1mac.sit into stuffit expander.
Stuffit Expander opens.
It spits me this :
"[BLAHBLAHBLAH CUD NOT OPEN BLAHBLAHBLHA] The archive may be damaged (Error #17537)"

I tried to reinstall stuffit expander, try on another computer (with google chrome, naturally, maybe i should try another downloader).

Please help me !

Robin


I also cannot open the sit files that are offered on the site; has anyone got this to work?
m0nk3y-1
New User
New User
 
Posts: 1
Joined: Sun Sep 17, 2017 1:40 pm
Blog: View Blog (0)


Previous

Return to Application

Who is online

Users browsing this forum: No registered users and 0 guests